Emerge Pre-Requisites

This document outlines the pre-requisites that must be in place before a successful installation of Emerge can take place.

Emerge comprises two ‘pieces’ of software. The Emerge device software, an app installed on the mobile devices, and the Emerge Server software installed in the school, or in a local authority.

  1. Emerge Device Software: this is the app that will need to be installed on each of the devices you’d like to run Emerge.  The Emerge Device Software communicates with the Emerge Server to receive and send MIS information.
  2. Emerge Sever Software.  The Emerge Server Software talks to your MIS system extracting student and staff information that it to devices running the Emerge app.Emerge Software 1

 

The remainder of this page outlines the supported devices and pre-requisites that must be in place in order to effectively communicate between MIS, Emerge server software and the devices that will ensure a successful installation of Emerge.

Emerge Devices

The Emerge app works on Android, Apple iOS and Windows 8.1 devices meeting the minimum requirements detailed below.

Emerge now also supports Emerge Desktop, enabling users to access Emerge data via a compatible browser on any device

Show Device Requirements for the app

Emerge Devices - Apple iOS

Any Apple device capable of running Apple iOS 7 or higher will run Emerge.

Supported Apple Devices

The following Apple devices are supported, the model number can be found on the back of the device.

Device FamilyDevice NameModel NumberModel ID
iPhone
iPhone 4A1332iPhone3,1
iPhone 4SA1387iPhone4,1
iPhone 5A1429iPhone5,2
iPhone 5CA1457iPhone5,4
iPhone 5SA1288iPhone6,2
iPhone 6A1586iPhone7,2
iPhone 6 PlusA1524iPhone7,1
iPhone 6SA1688iPhone8,1
iPhone 6S PlusA1687iPhone8,2
iPhone SE A1723iPhone8,4
iPhone 7 A1778iPhone9,3
iPhone 7 PlusA1784iPhone9,4
iPod
iPod Touch 5th GenerationA1421iPod5,1
iPod Touch 6th GenerationA1574iPod7,1
iPad
iPad 3GA1337iPad1,1
iPad 2 (Wi-Fi), (Wi-Fi+3G)A1395, A1396, A1397iPad2,1, iPad 2,2, iPad 2,3
iPad 3rd Generation (WiFi), (WiFi+Cellular)A1416, A1430, A1403iPad3,1, iPad 3,2, iPad 3,3
iPad 4th Generation (WiFi), (WiFi+Cellular)A1458, A1459, A1460iPad3,4, iPad 3,5, iPad 3,6
iPad Mini
iPad Mini 1st Generation (WiFi), (WiFi+Cellular)A1432, A1454, A1455iPad2,5, iPad 2,6, iPad 2,7
iPad Mini 2nd Generation (WiFi), (WiFi+Cellular)A1489, A1490, A1491 iPad4,4, iPad4,5, iPad4,6
iPad Mini 3rd Generation (WiFi), (WiFi+Cellular)A1599, A1600, A1601iPad4,7, iPad4,8, iPad4,9
iPad Mini 4th Generation (WiFi), (WiFi+Cellular)A1538, A1550iPad5,1, iPad5,2
iPad Air
iPad Air (WiFi)A1475iPad4,2
iPad Air (WiFI + Cellular)A1474iPad 4,3
iPad Air 2 (Wi-Fi)A1566iPad5,3
iPad Air 2 (Wi-Fi + cellular)A1567iPad5,4
iPad Pro
iPad Pro 12.9" (Wi-Fi) (Wi-Fi + cellular)A1584, A1652iPad6,7, iPad6,8
iPad Pro 9.7" (Wi-Fi) (Wi-Fi + cellular)A1673, A1674iPad6,3, iPad6,4
Model numbers in italics above will support Emerge if all other pre-requisites are met, however the device itself will not work over the mobile data network as it has a non-European Cellular chip not supported by European networks. It can be used on Wi-Fi in the UK however.

iOS 7 is a pre-requisite for the Emerge application.  The devices listed below can’t run iOS 7 and consequently cannot run Emerge.

Unsupported Apple Devices
Device Model Number Model ID
Original iPhone A1203 iPhone1,1
iPhone 3G A1241 iPhone1,2
iPhone 3GS  A1303 iPhone2,1
iPod Touch 1st, 2nd, 3rd and 4th Generation A1213, A1288, A1318, A1367 iPod1,1, iPod2,1, iPod3,1, iPod4,1
iPod without Touch Screen Various Various
iPod Nano Various Various
iPad (1st Generation) A1219 iPad1,1
Apple TV Various Various
Apple Watch Various Various

 

 

Emerge Devices - Android

A wide range of devices have been tested with Emerge for Android, but as there is a constantly changing landscape of devices running Android, it would be impossible to provide a totally comprehensive list. 

The minimum requirements therefore to run Emerge for Android are:

  • Android version 2.3.5 (Gingerbread)
    • Minimum version for the today screen in Emerge for Schools is Android version 3.0 (Honeycomb) however all other features will work on 2.3.5 and above.
  • Android Device with Wi-Fi
  • Internet Access (from device)
  • 10MB Memory
    • Extra memory can be provided on an External SD Card if internal memory is insufficient. Larger data sets may require more memory, and smaller data sets may work with less.
  • 768MB RAM for integration with Messenger and larger datasets. Lower RAM will work with other features.

A list of devices known to be running Emerge in schools across the country is provided for guidance.

Show 'Live' Android devices

Please note this list is provided as guide only and is subject to change.

Acer Devices
  • A500
Archos Devices
  • ARCHOS 80 COBALT
  • ARCHOS 80 TITANIUM
  • ARCHOS 97 TITANIUMHD
Asus Devices
  • ASUS Transformer Pad TF300T
  • ASUS Transformer Pad TF700T
Dell
  • Dell Streak 7
Google
  • Nexus 7
  • Galaxy Nexus
  • Nexus 10
  • Nexus One
  • Nexus 4
  • Galaxy Nexus
  • Nexus S
HTC
  • Desire HD
  • HTC Desire
  • HTC Desire C
  • HTC Desire HD A9191
  • HTC Desire S
  • HTC Desire X
  • HTC One
  • HTC One S
  • HTC One V
  • HTC One X
  • HTC One X+
  • HTC Sensation Z710e
  • HTC Vision
  • HTC Wildfire S A510e
  • HTC Flyer P512
  • HTC HD2
  • HTC Hero
  • HTC Sensation XE with Beats Audio Z715e
  • HTC Wildfire
  • HTC Wildfire S
LG
  • LG-P880
  • LG-P880
  • LG-P920
Motorola
  • XT910
  • MotoA953
Samsung
  • GT-I8150
  • GT-I9000
  • GT-I9100
  • GT-I9100P
  • GT-I9300
  • GT-I9505
  • GT-N7000
  • GT-N7100
  • GT-N8000
  • GT-P3110
  • GT-P5100
  • GT-P7500
  • GT-S5570
  • GT-S5830
  • GT-I5800
  • GT-I8160
  • GT-I8190
  • GT-I8190N
  • GT-I9003
  • GT-I9082
  • GT-I9100G
  • GT-I9195
  • GT-I9305
  • GT-N5110
  • GT-N7100-ProBam
  • GT-N7105
  • GT-N8010
  • GT-P1010
  • GT-P5110
  • GT-P7310
  • GT-P7510
  • GT-S5360
  • GT-S5830i
  • GT-S5839i
  • GT-S6310N
  • GT-S6810P
  • GT-S7500
  • GT-S7710
  • SM-N9005
  • SM-T210

 

Sony
  • C6603
  • LT26i
  • MT15i
  • ST26i
  • Sony Tablet S
Tesco
  • Hudl HT7S3
Unknown Manufacturer

 

  • 3310-9506
  • A1_07
  • A10
  • Ainovo Flame
  • AT100
  • AT10-A
  • AT200
  • AT300SE
  • AZ210A
  • B1-A71
  • BNTV400
  • CMS63486
  • CnM TouchPad 9DC
  • E15i
  • GOCLEVER
  • GoTab GBT9
  • KFOT
  • KFTT
  • LT18i
  • LT22i
  • LT30p
  • M1001
  • M701C
  • ME173X
  • ME301T
  • MID
  • MT11i
  • MZ601
  • MZ604
  • PIXELDROID HD2
  • PMP5880D
  • rk30sdk
  • Scroll Excel
  • Scroll Extreme
  • Scroll Extreme ll
  • Scroll Pocket
  • sdk
  • SGPT12
  • SK17i
  • SoftwinerEvb
  • ST18i
  • ST21i
  • ST25i
  • ST27i
  • T01A
  • T05A
  • T10A
  • TAB-PROTAB2-IPS9
  • Transformer Prime TF201
  • Transformer TF101
  • TWD_MID
  • U30GT 2
  • ViewPad 10e
  • VOYAGER
  • VS TOUCHTAB 7
  • WT19i
  • X10i
  • x86_64
  • Xenta TAB9-200
  • XOOM 2
  • YP-G70
  • ZT ICS

 

 


Emerge Devices - Windows 8.1

A wide range of devices have been tested with Emerge for Windows 8.1, but as there is a constantly changing landscape of devices running Windows, it would be impossible to provide a totally comprehensive list. 

The minimum requirements therefore to run Emerge for Windows 8.1 are:

  • Emerge runs on almost any Windows 8.1 device, including Windows RT 8.1 tablets, that meets Microsoft’s minimum system requirements.
    • Windows 8.1 should not be confused with Windows 8, Windows Phone 8 or Windows Phone 8.1; Emerge does not currently support the Windows Phone platform.
  • Your device must have a minimum screen resolution of 1366 x 768.

  • To install Emerge from the Windows Store you’ll need an active Internet connection and a Microsoft account.

  • To use Emerge you’ll need either an active Internet connection or a connection to your school network.

 

Show Emerge Desktop Requirements

Emerge Desktop will run on any device that has internet connectivity and is capable of running a modern browser.

 

 

Emerge Supported Management Information Systems

Currently Emerge Mobile, when accessed via an app on a smartphone or tablet, supports Capita SIMS and Advanced Learning CMIS.

SIMS_Logo Serco - Facility CMIS

 

Currently Emerge Desktop is supported with Capita SIMS only.

Emerge Desktop Screenshot_Icon SIMS_Logo

 

A Note of Caution - Due to the way in which the Serco ePortal software has been written, Emerge is limited to supporting 7 lesson attendance codes.  However, it is unusual for a school to use more than this.


Xporter

A component part of the Emerge solution is Groupcall Xporter and therefore the same pre-requisites must be met.

This includes;

  • Xporter Hardware requirements
  • Xporter Software requirements
  • MIS Specific Requirements
  • Xporter Internet Access
Show Xporter Pre-Requisites

Xporter Pre-Requisites

Where should I install Groupcall Xporter?

Groupcall recommends, where possible, that Xporter is installed on the MIS server. This will reduce potential complexity connecting to the MIS and will ensure that the Xporter installation is as highly available as the server.

If this is not possible in your environment, a suitable additional server or workstation will suffice. Please bear in mind that this machine should be left powered on at all times, this will ensure accuracy and availability of data. It must also have access to the MIS data and meet the pre-requisites detailed below.

Xporter Hardware requirements

Xporter has negligible hardware requirements and in most cases should go unnoticed on a computer running at least a 1.6GHz processor with at least 1GB of memory. The Disk Space required varies by extracts in use and how many you have installed, but as a rule of thumb the typical installation will need no more than 250MB working space, however busy installations can cache up to 1GB. An active internet connection is also required, this can be wireless, however a wired connection is usually more reliable.


 

Xporter Software requirements

Groupcall Xporter requires the following, and any additional MIS-specific requirements as below;

  • Administrator access to the computer
    • Both during installation and post-install to run the Xporter Management Console on an on-going basis
  • Microsoft .net Framework 4.6.2
  • Microsoft .net Framework 4.5 Full (not Client Profile)
    • To be installed alongside the SIMS workstation client.
    • This must be enabled as a feature via Server Manager.
  • Microsoft .net Framework 3.5 SP1
    • This must be enabled as a feature via Server Manager.
    • Ensuring  this is available ahead of installation will significantly shorten the installation process as certain systems require a restart as part of the .net installation.
  • A Supported Windows Version
    • Windows Server
      • 2008 R2,
      • 2012,
      • 2012 R2
    • Windows Client (you should always try to install on a server when you are able to).
      • Windows 7
      • Windows 8.1
      • Windows 10
  • Older versions of Windows;
    • Microsoft have now discontinued support for Windows XP and Windows Server 2003.
    • Xporter will continue to run on these systems for a period of time but newer versions of Xporter are not guaranteed to be compatible.
    • Following best practices for data security you should migrate away from these Windows versions as soon as possible.

 

 

MIS Specific Xporter Requirements

Xporter for SIMS.net Pre-Requisites

Xporter for SIMS.net Pre-Requisites

Xporter for SIMS.net requires the SIMS Workstation to be installed on the computer and meet the following requirements:

  • Running the current release of SIMS.net
  • Running the same version as the SIMS SQL database schema
  • Installed on a local fixed disk
  • Be able to log in to SIMS
    • Using a dedicated SIMS user account for Xporter with the following permissions:
      Term: Dedicated SIMS user account.
      Definition: An account in SIMS specifically set-up for the sole purpose of allowing Xporter to access the SIMS data.
      Notes: A regular user account should not be used as this is subject to password expiry/changes which would then render Xporter unable to access the SIMS data thus preventing any dependent systems from syncing. We recommend using an account with the user name "groupcall" and a suitably strong password of your choice - see this video for a demo of the process.
      • Personnel Officer
      • School Administrator
      • Senior Management Team
      • Third Party Reporting
  • Be able to pass the Document Server connection test.

 

Xporter for Facility CMIS Pre-Requisites

Xporter for Facility CMIS Pre-Requisites

  • Xporter for Serco Facility requires access to Facility database via a .CDB file.
  • Xporter connects to the Facility database using an SQL user account. Create or make available an SQL user that is a member of the STUD_ADMIN schema on the Facility database.
    • The inbuilt, but often hidden, STUD_ADMIN user is typically used for this.
  • If ePortal is installed to a separate server other than the CMIS database, then the recommended installation location is the ePortal server.
  • Additional requirements where the API server integration is required.
In order to run Emerge with CMIS you must...
  1. be running, as a minimum,
    • Version 10.1.18 of Facility or above
    • ePortal version 10.1 or above
  2. Install Emerge Server on the ePortal Server.
  3. not use trusted logins to access the .CDB file; an SQL user account should be used.

 

Xporter Internet Access

Groupcall Services require access to the following URLs in order to operate effectively:

 

  • https://dashboard.groupcall.com/ - To report health status and receive repair instructions
    • Please note this is a secured URL, i.e. it is HTTP + SSL = HTTPS. You must be able to connect to the HTTPS URL

 

 

These addresses can be accessed via proxy; the Xporter installer will copy the proxy settings from the current user at installation. Please ensure they are white-listed as appropriate.

Depending on the purpose of your installation there may be other URLs that require access, for example, a web service upload URL or a SIF Zone Integration Server URL.

 

 


Network Requirements

Show Network Infrastructure detail
Every school/establishment running Emerge is set up in a slightly different manner. In order to make sure that Emerge can communicate across your network it is important that you provide us with the following information and can make the required network connections.

 

Emerge Network Infrastructure

Every school/establishment running Emerge is set up in a slightly different manner.  In order to make sure that Emerge can communicate across your network it is important that you provide us with the following information and can make the required network connections.

In the school - If you are using Emerge over Wi-Fi

Proxy Details

If the Emerge devices or Emerge Server Software need to pass through a school proxy server in order to reach the Internet, please make sure that you have the:

  • Proxy URL
  • Proxy username and password

Internet access is required for installing, updating and registering software on the devices and server.

Connecting Devices

  1. Can you connect to the internet from a device connected to the wireless network? Try opening Google and performing a search to prove Internet connectivity.
  2. Is it possible to make a connection to the Emerge Server?
  3. Does this connection depend on use of the proxy server?

Out and about - If you are accessing Emerge from outside the school

Are you planning to connect any teacher or school devices over a mobile data connection or from non-school WiFi? Please let Groupcall know and we’ll set up the secure Service Bus during the installation.

Service bus is a required component of Emerge Desktop. If you would like to see technical and networking detail about Service Bus, please have a look at this document.


Emerge Desktop MIS Requirements

In addition to the general Emerge Pre-Requisites, for Emerge Desktop you will also need to ensure that your MIS and Active Directory are configured to allow user provisioning by the Groupcall IDaaS agent.

SIMS

sims_staffemail

In order for a user to access Emerge Desktop they must be set up as a member of Staff in SIMS;

  • They must have an email address in the SIMS record.
    • This has to be their school address
      • (i.e. one that has a common domain for all staff such as @aisley.sch.uk and not gmail.com etc).
    • This email address must be marked as their main work email address.

This email address will form their login username.

Active Directory

activedirectory_emailattributeIf you would like users to take advantage of single sign on and use their Active Directory passwords with their email addresses to sign on to Emerge Desktop, you must ensure;

  • That the email address in SIMS matches the Email attribute in your Active Directory.

 

Please note, that someone with knowledge of the AD should be available during the installation.

If you find a user cannot sign in, you should check the above requirements initially.

 

 

 

 

 

 

 

 

 

 

 

 


Pre-installation checklist

Preparing these pre-requisites in advance will help ensure your installation runs smoothly. If you have any problems with these, the support representative carrying out the install will be able to assist, however it should be noted that this may result in the install having to be postponed whilst requirements are put in place.

The server where Emerge will be installed;

Additionally for Emerge Desktop...

 

Emerge Support Tool

In support of pre-requisite checking, you can make use of the Emerge Support Tool.

Next Steps...

If you need any further assistance or get in to any difficulty, then please contact Groupcall Support. If the issue affects Groupcall Partner products you should refer to the support arrangements for that specific Groupcall Partner.

…And Finally

Have you followed Groupcall on Twitter and Facebook? Stay informed, get the latest news, updates and useful tips on all of our products!